Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Jose Luis Benitez  
#1 Posted : Wednesday, June 19, 2024 8:16:14 AM(UTC)
Jose Luis Benitez

Rank: Newbie

Groups: Registered
Joined: 6/19/2024(UTC)
Posts: 0


I'm just unable to receive a refresh_token when creating a successfull Oauth authentication with Gmail (for sending with SMTP)

Response:
{
"access_token": "ya29.a0..pX7akJmlStQUtrxVeHGX2Mi9sakaWezHax0spWec9QV4A0179",
"expires_in": 3593,
"scope": "openid https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/userinfo.profile https://mail.google.com/",
"token_type": "Bearer",
"id_token": "eyJhbGci..._l2hfOAg"
}

Could it be something related to that App is still not reviewed?

I've added &access_type=offline as its mentioned in the documentation with no luck.

Thanks.
Jose Luis Benitez  
#2 Posted : Thursday, June 20, 2024 2:31:41 AM(UTC)
Jose Luis Benitez

Rank: Newbie

Groups: Registered
Joined: 6/19/2024(UTC)
Posts: 0

Just added:

authUri += '&access_type=offline';
authUri += '&prompt=consent';

At the end of the URL when opening the Oauth screen.
ivan  
#3 Posted : Thursday, June 20, 2024 4:40:51 AM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,149

Thanks: 9 times
Was thanked: 54 time(s) in 54 post(s)
please try to use

&prompt=login
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2024, Yet Another Forum.NET
This page was generated in 1.619 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AIFEI Software Limited & AdminSystem Software Limited.