Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
adamh  
#1 Posted : Wednesday, February 3, 2016 9:13:39 AM(UTC)
adamh

Rank: Newbie

Groups: Registered
Joined: 2/3/2016(UTC)
Posts: 3

The client application (non-async) hangs on the SendMail() function.

Looking at the logs on the receiving server, we found that the messages were submitted and accepted, but the receiving server never sends back a QUIT so my application freezes indefinitely. It seems as though some servers will deliver the messages and others will not.

I am not getting an error or logging back from the control. I am trying to get logs from the receiving servers. Does anyone know what can cause this behavior?

ivan  
#2 Posted : Wednesday, February 3, 2016 8:30:40 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,010

Thanks: 9 times
Was thanked: 37 time(s) in 37 post(s)
Could you generate a log file with LogFileName property and send it to support@emailarchitect.net?
adamh  
#3 Posted : Thursday, February 4, 2016 9:32:52 AM(UTC)
adamh

Rank: Newbie

Groups: Registered
Joined: 2/3/2016(UTC)
Posts: 3

Originally Posted by: ivan Go to Quoted Post
Could you generate a log file with LogFileName property and send it to support@emailarchitect.net?


No because it hangs on SendMail() and no log gets generated.

I will send a log from the receiving server....

adamh  
#4 Posted : Friday, February 5, 2016 7:50:12 AM(UTC)
adamh

Rank: Newbie

Groups: Registered
Joined: 2/3/2016(UTC)
Posts: 3

This was fixed by changing the .TransferEncoding from the default to 4 for base64.

Special thanks to Ivan for helping figure this out.
Fabio  
#5 Posted : Friday, February 19, 2016 6:46:20 AM(UTC)
Fabio

Rank: Newbie

Groups: Registered
Joined: 2/19/2016(UTC)
Posts: 2

Hello,
i am having the same problem with compact framework. My device is working with windows CE and hang on SendMail function call. Program is in C# language and it completely freeze the device so i have no idea what happen...i place some log traps and i can only see that the problem is on SendMail call.

Based on precedent message i use:
TransferEncoding = TransferEncodingType.EncodingQuotedPrintable;
ivan  
#6 Posted : Sunday, February 21, 2016 4:57:57 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,010

Thanks: 9 times
Was thanked: 37 time(s) in 37 post(s)
Originally Posted by: Fabio Go to Quoted Post
Hello,
i am having the same problem with compact framework. My device is working with windows CE and hang on SendMail function call. Program is in C# language and it completely freeze the device so i have no idea what happen...i place some log traps and i can only see that the problem is on SendMail call.

Based on precedent message i use:
TransferEncoding = TransferEncodingType.EncodingQuotedPrintable;


could you generate a log file with LogFileName property and send it to support@emailarchitect.net?
Fabio  
#7 Posted : Sunday, February 21, 2016 11:29:28 PM(UTC)
Fabio

Rank: Newbie

Groups: Registered
Joined: 2/19/2016(UTC)
Posts: 2

No...device (not only application) hangs but this aspect make me suspicious as device should not hang. This is probably because i have a limited amount of memory (64Mb) and the SendMail call saturated the already limited memory (mail size with one attachment was around 500Kb). The solution i am trying now is to reduce the attachment size and then send mail..it seems to work but i still have to going on deeper tests..

Thank you
Fabio
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.256 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.