Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Cameron Peters  
#1 Posted : Monday, April 13, 2020 6:48:04 PM(UTC)
Cameron Peters

Rank: Newbie

Groups: Registered
Joined: 4/13/2020(UTC)
Posts: 0
Canada
Location: Calgary

I am using the samples app (AppProject1), which I wish to use to send emails through gmail.

Unfortunately, when I try to send a email, I'm not even allowed to enter a password. I see the google login, and after I enter my email address, the next window says:

Sign in with Google

Couldn't sign you in

This browser or app may not be secure.

Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.

What do I need to change? I see this in the email "If you got "This app isn't verified" information, please click "advanced" -> Go to ... for test.", but I don't see anywhere to click an "advanced" button or hyperlink.

For now, I am using the build in client id and secret in the sample app. Once I get the basics working, I'll apply for our own.

Best regards,

~ Cameron

Edited by user Monday, April 13, 2020 7:39:44 PM(UTC)  | Reason: Not specified

ivan  
#2 Posted : Monday, April 13, 2020 11:04:32 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,067

Thanks: 9 times
Was thanked: 43 time(s) in 43 post(s)
Because Web Browser control is used for OAUTH,
Web browser control uses IE7 rendering mode by default,
it doesn't support latest Google Web Login Page.

You should install IE 10/IE11 (recommended) or later version on your current machine,
and then add/mergin the following registry values to use IE 10 mode.

"AppProject1.exe" is your executable file name.
In current project, it is "AppProject1.exe"
If you debug it in VS, please also add "AppProject1.vshost.exe"

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"AppProject1.exe"=dword:00002AF9
"AppProject1.vshost.exe"=dword:00002AF9

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"AppProject1.exe"=dword:00002AF9
"AppProject1.vshost.exe"=dword:00002AF9

Appendix - Web Browser Control Mode:

11001 (0x2AF9) Internet Explorer 11. Webpages are displayed in IE11 Standards mode, regardless of the !DOCTYPE directive.
11000 (0x2AF8) Internet Explorer 11. Webpages containing standards-based !DOCTYPE directives are displayed in IE11 mode.
10001 (0x2711) Internet Explorer 10. Webpages are displayed in IE10 Standards mode, regardless of the !DOCTYPE directive.
10000 (0x2710) Internet Explorer 10. Webpages containing standards-based !DOCTYPE directives are displayed in IE10 mode.
9999 (0x270F) Internet Explorer 9. Webpages are displayed in IE9 Standards mode, regardless of the !DOCTYPE directive.
9000 (0x2328) Internet Explorer 9. Webpages containing standards-based !DOCTYPE directives are displayed in IE9 mode.
8888 (0x22B8) Webpages are displayed in IE8 Standards mode, regardless of the !DOCTYPE directive.
8000 (0x1F40) Webpages containing standards-based !DOCTYPE directives are displayed in IE8 mode.
7000 (0x1B58) Webpages containing standards-based !DOCTYPE directives are displayed in IE7 Standards mode. This mode is kind of pointless since it's the default.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.061 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.