Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
TURCK  
#1 Posted : Monday, January 29, 2018 7:37:40 AM(UTC)
TURCK

Rank: Newbie

Groups: Registered
Joined: 1/29/2018(UTC)
Posts: 3
France
Location: Gamarde

Google translation
EASendMail SMTP Component with delphi
Hello
until 2 or 3 days ago, I used this component in one of my programs. Everything was working normally.
Now I can not send an attached file with the body of the message, either one or the other.
This also happens in the simple example provided with the component.
Would anyone have an idea of the problem and especially its solution.
Would there have been a change in Windows?
Thank you
ivan  
#2 Posted : Monday, January 29, 2018 5:41:50 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,013

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
Hi, what error did you get? Could you generate a log file with LogFileName property and send it to support@emailarchitect.net?
TURCK  
#3 Posted : Tuesday, January 30, 2018 3:02:05 AM(UTC)
TURCK

Rank: Newbie

Groups: Registered
Joined: 1/29/2018(UTC)
Posts: 3
France
Location: Gamarde

Hello and thank you for your quick response
the component is used since September 2016 in a software of a Sports Federation to send the results after the meetings between 2 teams.
The meeting sheet is sent by attached file with a small text wishing good reception.
Everything worked perfectly until 25/01/2018 (more than 3000 users per weekend)

test 1 - text only in HtmlEditor -> Message delivered -> message received
test 2 - attached file only, no text in HtmlEditor -> Message delivered -> message received
test 3 - attached file (PDF) + text in HtmlEditor -> Message delivered -> message never arrives
test 4 - attached file (PDF) + image in HtmlEditor -> Message delivered -> message received

there is no error message, the mail is still delivered but in example 3 does not arrive at destination.
ivan  
#4 Posted : Tuesday, January 30, 2018 3:17:00 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,013

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
test 3 - attached file (PDF) + text in HtmlEditor -> Message delivered -> message never arrives

Please check it like this:

oSmtp.SaveMail('d:\myfolder\test.eml'); // add this line here, then you can get a copy of the message.
oSmtp.LogFileName := 'd:\myfolder\smtplog.txt'; // add this line, it will generate full debug log.
oSmtp.SendMail ..

1, Please open test.eml and see if the content is corrupt.
2. Please check if there is any error in the log file.

If there is no error in log file, that means the email has been submitted to server, server will deliver it to recipient in background.
If any error occurred with the email delivery, your sender mailbox should receive non-delivery report from your server.
TURCK  
#5 Posted : Tuesday, January 30, 2018 11:09:00 PM(UTC)
TURCK

Rank: Newbie

Groups: Registered
Joined: 1/29/2018(UTC)
Posts: 3
France
Location: Gamarde

Hello
Without any modification of the program, everything is back to normal, at least at my ISP. I will see the next weekend if it is the same for other ISPs.
I think there was a change in a Windows update and the ISPs were quick to fix the bug that lasted 4 days for dozens of people.
Thank you for your help.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.058 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.