Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Christoph Huber  
#1 Posted : Friday, November 17, 2017 10:06:53 AM(UTC)
Christoph Huber

Rank: Newbie

Groups: Registered
Joined: 11/17/2017(UTC)
Posts: 2
Switzerland
Location: Zürich

Internal Mailserver/Exchange,
Outbound Mail out goes through SmartHost of the Provider .... all perfect, DKIM runs.

Inbound Mail comes with SmartPop / PopCon and is delivered to the Exchange.
Since the POP to SMTP is the Sender, all Mails have SPF-SoftFail.

Is there a way to handle this scenario?
For me it's a show-stopper and worth a feature request.
ivan  
#2 Posted : Friday, November 17, 2017 4:47:16 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 995

Thanks: 9 times
Was thanked: 34 time(s) in 34 post(s)
All the emails from POP Connector should be sent from a specific IP address, you can add that IP address to trustedIPAddresses settings.

Christoph Huber  
#3 Posted : Friday, November 17, 2017 11:04:14 PM(UTC)
Christoph Huber

Rank: Newbie

Groups: Registered
Joined: 11/17/2017(UTC)
Posts: 2
Switzerland
Location: Zürich

Originally Posted by: ivan Go to Quoted Post
All the emails from POP Connector should be sent from a specific IP address, you can add that IP address to trustedIPAddresses settings.



Thanks for the quick answer, now the mails do not soft-fail anymore.
But this can not be the solution, since all the mails now come from a trusted sender, spf-filtering does not "work" anymore.

I had hoped for a better solution, like going back 1 or 2 steps in the "Received:" history to check if there is a spf-designated smtp-server.
Or give a mechanism to specify the "external-receiving-mailserver" and then to check if this server has received the mail from a spf-designated smtp-server.

Edited by user Saturday, November 18, 2017 1:20:29 AM(UTC)  | Reason: Not specified

ivan  
#4 Posted : Saturday, November 18, 2017 8:14:37 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 995

Thanks: 9 times
Was thanked: 34 time(s) in 34 post(s)
could you do a test like this, remove POP IP from trustedIPAddresses, enable Full debug log, use Pop Connector to retrieve an email, send the inbound log in dkim installation path\log folder to support@emailarchitect.net, i will think over a solution for you. Please change log level back to only error and add the IP to trusted IP addresses again.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2018, Yet Another Forum.NET
This page was generated in 0.091 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.